Ignore:
Timestamp:
Jan 22, 2012, 2:51:25 PM (10 years ago)
Author:
Ralph Meijer <ralphm@…>
Branch:
default
Message:

Cleanups leading up to Wokkel 0.7.0.

As we now depend on Twisted 10.0.0 or higher, the following classes and
interfaces were deprecated:

This also resolves all Pyflakes warnings, changes links for www.xmpp.org to
xmpp.org and fixes the copyright notice in LICENSE to include 2012.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • wokkel/test/test_component.py

    r96 r165  
    88from zope.interface.verify import verifyObject
    99
    10 from twisted.internet import defer
    1110from twisted.python import failure
    1211from twisted.trial import unittest
    13 from twisted.words.protocols.jabber import ijabber, xmlstream
     12from twisted.words.protocols.jabber import xmlstream
     13from twisted.words.protocols.jabber.ijabber import IXMPPHandlerCollection
    1414from twisted.words.protocols.jabber.jid import JID
     15from twisted.words.protocols.jabber.xmlstream import XMPPHandler
    1516from twisted.words.xish import domish
    16 
    17 try:
    18     from twisted.words.protocols.jabber.ijabber import IXMPPHandlerCollection
    19     from twisted.words.protocols.jabber.xmlstream import XMPPHandler
    20 except ImportError:
    21     from wokkel.subprotocols import IXMPPHandlerCollection, XMPPHandler
    2217
    2318from wokkel import component
     
    4035        """
    4136        verifyObject(IXMPPHandlerCollection, self.component)
    42 
    4337
    4438
Note: See TracChangeset for help on using the changeset viewer.