Ignore:
Timestamp:
Mar 5, 2018, 5:12:30 PM (3 years ago)
Author:
Ralph Meijer <ralphm@…>
Branch:
default
committer:
Ralph Meijer <ralphm@ik.nu> 1520266418 -3600
hg-git-rename-source:
git
Message:

Use incremental instead of t.p.versions everywhere

twisted.python.versions is a precursor of the incremental library
but isn't fully API compatible. This caused breakage with older Twisted
versions. Switching to incremental everywhere resolves this. Also fix
the version to at least 16.9.0, which introduced the release_candidate
parameter.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • wokkel/subprotocols.py

    r194 r240  
    1717from twisted.python.compat import iteritems, itervalues
    1818from twisted.python.deprecate import deprecatedModuleAttribute
    19 from twisted.python.versions import Version
    2019from twisted.words.protocols.jabber import error, ijabber, xmlstream
    2120from twisted.words.protocols.jabber.xmlstream import toResponse
     
    2423from twisted.words.xish.domish import IElement
    2524
     25from incremental import Version
     26
    2627deprecatedModuleAttribute(
    27         Version("Wokkel", 0, 7, 0),
     28        Version("wokkel", 0, 7, 0),
    2829        "Use twisted.words.protocols.jabber.xmlstream.XMPPHandlerCollection "
    2930                "instead.",
Note: See TracChangeset for help on using the changeset viewer.