Changeset 210:cb2ffe41c24d for setup.py


Ignore:
Timestamp:
Oct 3, 2016, 9:06:18 AM (5 years ago)
Author:
Ralph Meijer <ralphm@…>
Branch:
default
rebase_source:
94b4b315b9cd5d6b8796c024e44df87a5aaaf019
Message:

Set mininum Twisted versions for setup.py.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • setup.py

    r179 r210  
    44# See LICENSE for details.
    55
     6import sys
    67from setuptools import setup
    78
     
    2829    egg_info.write_toplevel_names = _hacked_write_toplevel_names
    2930
     31if sys.version_info < (3, 0):
     32    requiredTwisted = "15.5.0"
     33else:
     34    requiredTwisted = "16.4.0"
     35
    3036setup(name='wokkel',
    31       version='0.7.1',
     37      version='16.0.0',
    3238      description='Twisted Jabber support library',
    3339      author='Ralph Meijer',
     
    4551      zip_safe=False,
    4652      install_requires=[
    47           'Twisted >= 10.0.0',
     53          'Twisted >= %s' % requiredTwisted,
    4854          'python-dateutil',
    4955      ],
Note: See TracChangeset for help on using the changeset viewer.