Opened 13 years ago

Closed 11 years ago

#1 closed task (fixed)

Add server side code from Twisted branch and sandbox

Reported by: ralphm Owned by: ralphm
Priority: normal Milestone: 0.6
Component: generic Keywords:
Cc: ralphm, tofu

Description


Change History (8)

comment:1 Changed 13 years ago by anonymous

  • Component set to generic

comment:2 Changed 12 years ago by tofu

Is there a reason that you changed the parameters to xmppim.Presence? Is it just for readability? Looks good so far, just wanted to ask that question.

comment:4 Changed 12 years ago by ralphm

  • Cc ralphm tofu added

Mostly because the presence stuff was designed for client side use, only. Within a server, most of the time there also is from attribute.

That said, there is way to much stuff in this particular branch. I was coincidently working on taking it apart, using different tickets, doing away with this branch and make this ticket an umbrella for the various server side stuff.

comment:5 Changed 12 years ago by tofu

That seems reasonable, similar to the router ticket in twisted? Splitting each part up as a ticket would be good, like router, s2s, session, etc. Right now I am mostly interested in using the s2s parts. :)

comment:6 Changed 12 years ago by ralphm

I imported the server factory and router code as mentioned in #29, #30. Next up is the server-to-server code, ticket #33.

comment:7 Changed 12 years ago by ralphm

  • Milestone set to 0.6

comment:8 Changed 11 years ago by ralphm

  • Resolution set to fixed
  • Status changed from new to closed

Since #33 has been closed, I am closing this ticket. Future server-side support can be resolved through new tickets.

Note: See TracTickets for help on using tickets.