Opened 10 years ago

Closed 10 years ago

#72 closed defect (fixed)

Incorrect handling of multiple child elements of 'pubsub' element in requests.

Reported by: ralphm Owned by: ralphm
Priority: normal Milestone:
Component: pubsub Keywords:
Cc:

Description

In the current parseElement logic, if only one child element of the pubsub element is expected, and one or more elements (in whatever namespace) follow the expected element, the very last child element is passed to the parse methods. This is caused by a reuse of the child variable from the loop.

Change History (1)

comment:1 Changed 10 years ago by ralphm

  • Resolution set to fixed
  • Status changed from new to closed

(In [f69b08281bec]) Properly pass verb element to parse methods, not just the last one.

Author: ralphm. Fixes: #72.

This also cleans up a few pyflakes warnings, including a masked test.

Note: See TracTickets for help on using tickets.